aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ocaml-qcheck
diff options
context:
space:
mode:
Diffstat (limited to 'testing/ocaml-qcheck')
-rw-r--r--testing/ocaml-qcheck/APKBUILD6
1 files changed, 1 insertions, 5 deletions
diff --git a/testing/ocaml-qcheck/APKBUILD b/testing/ocaml-qcheck/APKBUILD
index d100067b42..ac407efb92 100644
--- a/testing/ocaml-qcheck/APKBUILD
+++ b/testing/ocaml-qcheck/APKBUILD
@@ -3,7 +3,7 @@
pkgname=ocaml-qcheck
_pkgname=qcheck
pkgver=0.12
-pkgrel=0
+pkgrel=1
pkgdesc="QuickCheck inspired property-based testing for OCaml"
url="https://github.com/c-cube/qcheck"
arch="all !x86 !armhf !armv7 !s390x" # limited by ocaml aport
@@ -16,8 +16,6 @@ source="$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
- cd "$builddir"
-
dune build @install -p qcheck,qcheck-core,qcheck-ounit -j1 --no-buffer --verbose
}
@@ -26,8 +24,6 @@ check() {
}
package() {
- cd "$builddir"
-
mkdir -p "$pkgdir"/usr/lib/ocaml
dune install \
--destdir="$pkgdir" \