aboutsummaryrefslogtreecommitdiffstats
path: root/testing/opam/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/opam/APKBUILD')
-rw-r--r--testing/opam/APKBUILD49
1 files changed, 0 insertions, 49 deletions
diff --git a/testing/opam/APKBUILD b/testing/opam/APKBUILD
deleted file mode 100644
index 4d4001454f..0000000000
--- a/testing/opam/APKBUILD
+++ /dev/null
@@ -1,49 +0,0 @@
-# Contributor: Michael Zuo <muh.muhten@gmail.com>
-# Maintainer: Michael Zuo <muh.muhten@gmail.com>
-pkgname=opam
-pkgver=1.2.2
-pkgrel=0
-pkgdesc="OCaml Package Manager"
-url="http://opam.ocaml.org"
-arch="all"
-license="LGPL3"
-depends=""
-depends_dev="ocaml"
-makedepends="$depends_dev"
-install=""
-subpackages=""
-source="https://github.com/ocaml/$pkgname/releases/download/$pkgver/$pkgname-full-$pkgver.tar.gz"
-
-_builddir="$srcdir"/$pkgname-full-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
-build() {
- cd "$_builddir"
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --localstatedir=/var \
- || return 1
- make -j1 lib-ext all || return 1
-}
-
-package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
-}
-
-md5sums="7d348c2898795e9f325fb80eaaf5eae8 opam-full-1.2.2.tar.gz"
-sha256sums="15e617179251041f4bf3910257bbb8398db987d863dd3cfc288bdd958de58f00 opam-full-1.2.2.tar.gz"
-sha512sums="f095ef4c02e6a411ee115b508c7dc21cf6480f60ad5d84ed5ce5868afa1f6225ead0eb6703763d803edc22595e83db67cdd1a4ecab50ee2c62c20965b0542436 opam-full-1.2.2.tar.gz"