aboutsummaryrefslogtreecommitdiffstats
path: root/testing/open-vm-tools/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/open-vm-tools/APKBUILD')
-rw-r--r--testing/open-vm-tools/APKBUILD99
1 files changed, 0 insertions, 99 deletions
diff --git a/testing/open-vm-tools/APKBUILD b/testing/open-vm-tools/APKBUILD
deleted file mode 100644
index 99e65e5c92..0000000000
--- a/testing/open-vm-tools/APKBUILD
+++ /dev/null
@@ -1,99 +0,0 @@
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=open-vm-tools
-pkgver=2011.01.24
-_pkgsubver=354108
-pkgrel=2
-pkgdesc="The Open Virtual Machine Tools are the open source implementation of VMware Tools."
-url="http://open-vm-tools.sourceforge.net/"
-arch="all"
-license="LGPL"
-subpackages="$pkgname-gtk $pkgname-dev"
-makedepends="procps-dev libdnet-dev icu-dev glib-dev pkgconfig bash
- libtirpc-dev rpcgen icu-dev automake autoconf
- gtk+-dev libxext-dev libxinerama-dev libxtst-dev gtkmm-dev
- libnotify-dev libxrandr-dev
- "
-source="http://downloads.sourceforge.net/open-vm-tools/open-vm-tools-$pkgver-$_pkgsubver.tar.gz
- getloadavg-uclibc.patch
- codeset-uclibc.patch
- ecvt.patch
- iconv-uclibc.patch
- libm.patch
- open-vm-tools.initd
- procmgrposix.patch
- "
-
-_builddir="$srcdir"/$pkgname-$pkgver-$_pkgsubver
-
-prepare() {
- cd "$_builddir"
- for i in "$srcdir"/*.patch; do
- [ -r "$i" ] || continue
- patch -p1 -i "$i" || return 1
- done
-
- sed -i -e 's/__unused1/st_atim.tv_nsec/g' \
- -e 's/__unused2/st_mtim.tv_nsec/g' \
- -e 's/__unused3/st_ctim.tv_nsec/g' \
- lib/file/filePosix.c lib/hgfsServer/hgfsServerLinux.c \
- || return 1
-
- # workaround automake-1.10 issue
- # http://ramblingfoo.blogspot.com/2007/07/required-file-configrpath-not-found.html
- touch config/config.rpath
- aclocal -I m4 && autoconf && automake
-}
-
-build() {
- cd "$_builddir"
- ./configure --prefix=/usr \
- --disable-unity \
- --with-dnet \
- --with-icu \
- --with-procps \
- --with-x \
- --without-kernel-modules \
- --without-pam \
- || return 1
- make || return 1
-}
-
-package() {
- cd "$_builddir"
- make install DESTDIR=$pkgdir || return 1
-
- # one of the plugins seems to be linked to libhgfsServer
- # create a link to abuild gets happy
- ln -s open-vm-tools/plugins/vmsvc/libhgfsServer.so \
- "$pkgdir"/usr/lib/libhgfsServer.so.0
-
- # dont bother create a -dev package
- rm -f "$pkgdir"/usr/lib/*.a "$pkgdir"/usr/lib/*.la
- install -Dm644 "$srcdir"/open-vm-tools.desktop \
- "$pkgdir"/etc/xdg/open-vm-tools.desktop
- install -Dm755 "$srcdir"/open-vm-tools.initd \
- "$pkgdir"/etc/init.d/open-vm-tools
-}
-
-gtk() {
- pkgdesc="Xorg apps and plugins for open-vm-tools"
- mkdir -p "$subpkgdir"/usr/bin \
- "$subpkgdir"/usr/lib/open-vm-tools/plugins \
- "$subpkgdir"/etc/
- mv "$pkgdir"/usr/bin/vmware-toolbox \
- "$pkgdir"/usr/bin/vmware-user \
- "$subpkgdir"/usr/bin/
- mv "$pkgdir"/etc/xdg "$subpkgdir"/etc/
- mv "$pkgdir"/usr/lib/open-vm-tools/plugins/vmusr \
- "$subpkgdir"/usr/lib/open-vm-tools/plugins/
-
-}
-
-md5sums="b324efa55bb3f1198100cad838e9272b open-vm-tools-2011.01.24-354108.tar.gz
-49e2e394d0b567fa71fcd295e96bc1c8 getloadavg-uclibc.patch
-82840b6bed002284b9bd2358707ee826 codeset-uclibc.patch
-840e4d6ff3f53fc22bdedf4d64aabc91 ecvt.patch
-89c7449323ddac4666b73a8467baf95a iconv-uclibc.patch
-7d02fc25aba5c248f3d98dac238f175b libm.patch
-c96644aa42d611fae853a3a2095efc47 open-vm-tools.initd
-7b833102a56009bdfc2fef2fb9ffa297 procmgrposix.patch"