aboutsummaryrefslogtreecommitdiffstats
path: root/testing/openimageio/boost-python.patch
diff options
context:
space:
mode:
Diffstat (limited to 'testing/openimageio/boost-python.patch')
-rw-r--r--testing/openimageio/boost-python.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/testing/openimageio/boost-python.patch b/testing/openimageio/boost-python.patch
new file mode 100644
index 0000000000..c68d426311
--- /dev/null
+++ b/testing/openimageio/boost-python.patch
@@ -0,0 +1,12 @@
+diff --git a/src/python/CMakeLists.txt b/src/python/CMakeLists.txt
+index e58d372..649e9f3 100644
+--- a/src/python/CMakeLists.txt
++++ b/src/python/CMakeLists.txt
+@@ -18,6 +18,7 @@ if (NOT BOOST_CUSTOM)
+ # different names on different systems. Try the most common ones.
+ foreach (_py_lib python-${PYTHON_VERSION_FOUND} python
+ python${PYTHON_VERSION_MAJOR}
++ python${PYTHON_VERSION_MAJOR}${PYTHON_VERSION_MINOR}
+ python-py${PYTHON_VERSION_MAJOR}${PYTHON_VERSION_MINOR})
+ find_package (Boost QUIET COMPONENTS ${_py_lib})
+ string (TOUPPER ${_py_lib} _py_lib_name)