aboutsummaryrefslogtreecommitdiffstats
path: root/testing/openvas-cli/001-fortify-source.patch
diff options
context:
space:
mode:
Diffstat (limited to 'testing/openvas-cli/001-fortify-source.patch')
-rw-r--r--testing/openvas-cli/001-fortify-source.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/testing/openvas-cli/001-fortify-source.patch b/testing/openvas-cli/001-fortify-source.patch
new file mode 100644
index 0000000000..caab6920ef
--- /dev/null
+++ b/testing/openvas-cli/001-fortify-source.patch
@@ -0,0 +1,13 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index aae0c0e..1c4cc7d 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -202,7 +202,7 @@ configure_file (VERSION.in VERSION)
+ if (MINGW)
+ set (HARDENING_FLAGS "-Wformat -Wformat-security -O2 -D_FORTIFY_SOURCE=2")
+ else (MINGW)
+- set (HARDENING_FLAGS "-Wformat -Wformat-security -O2 -D_FORTIFY_SOURCE=2 -fstack-protector -Wl,-z,relro -Wl,-z,now")
++ set (HARDENING_FLAGS "-Wformat -Wformat-security -O2 -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -fstack-protector -Wl,-z,relro -Wl,-z,now")
+ endif (MINGW)
+
+ set (CMAKE_C_FLAGS_DEBUG "${CMAKE_C_FLAGS_DEBUG} -Werror")