aboutsummaryrefslogtreecommitdiffstats
path: root/testing/perl-dancer-plugin-auth-extensible
diff options
context:
space:
mode:
Diffstat (limited to 'testing/perl-dancer-plugin-auth-extensible')
-rw-r--r--testing/perl-dancer-plugin-auth-extensible/APKBUILD19
1 files changed, 6 insertions, 13 deletions
diff --git a/testing/perl-dancer-plugin-auth-extensible/APKBUILD b/testing/perl-dancer-plugin-auth-extensible/APKBUILD
index e83a2cea98..1a6b331d3d 100644
--- a/testing/perl-dancer-plugin-auth-extensible/APKBUILD
+++ b/testing/perl-dancer-plugin-auth-extensible/APKBUILD
@@ -4,43 +4,36 @@
pkgname=perl-dancer-plugin-auth-extensible
_pkgreal=Dancer-Plugin-Auth-Extensible
pkgver=1.00
-pkgrel=0
+pkgrel=1
pkgdesc="extensible authentication framework for Dancer apps"
-url="http://search.cpan.org/dist/Dancer-Plugin-Auth-Extensible/"
+url="https://metacpan.org/release/Dancer-Plugin-Auth-Extensible"
arch="noarch"
-license="GPL PerlArtistic"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
cpandepends="perl-dancer perl-crypt-saltedhash"
-cpanmakedepends=""
-cpancheckdepends=""
depends="perl-yaml $cpandepends"
-makedepends="perl-dev $cpanmakedepends"
-checkdepends="$cpancheckdepends"
+makedepends="perl-dev"
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/B/BI/BIGPRESH/$_pkgreal-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
- default_prepare || return 1
+ default_prepare
- cd "$builddir"
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
- cd "$builddir"
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
make
}
package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
check() {
- cd "$builddir"
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
make test
}