aboutsummaryrefslogtreecommitdiffstats
path: root/testing/perl-test-simple
diff options
context:
space:
mode:
Diffstat (limited to 'testing/perl-test-simple')
-rw-r--r--testing/perl-test-simple/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/perl-test-simple/APKBUILD b/testing/perl-test-simple/APKBUILD
new file mode 100644
index 0000000000..8122e47deb
--- /dev/null
+++ b/testing/perl-test-simple/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer:
+pkgname=perl-test-simple
+_realname=Test-Simple
+pkgver=0.98
+pkgrel=0
+pkgdesc="Perl modules for writing tests"
+url="http://search.cpan.org/~mschwern/Test-Simple-0.98/"
+arch="noarch"
+license="PerlArtistic"
+depends="perl"
+depends_dev=""
+makedepends="perl-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/M/MS/MSCHWERN/$_realname-$pkgver.tar.gz"
+_builddir="$srcdir"/$_realname-$pkgver
+
+build() {
+ cd "$_builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="a8b26c97440269b33dd79fd847c521d8 Test-Simple-0.98.tar.gz"