aboutsummaryrefslogtreecommitdiffstats
path: root/testing/pgbouncer/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/pgbouncer/APKBUILD')
-rw-r--r--testing/pgbouncer/APKBUILD60
1 files changed, 0 insertions, 60 deletions
diff --git a/testing/pgbouncer/APKBUILD b/testing/pgbouncer/APKBUILD
deleted file mode 100644
index b1c81c182f..0000000000
--- a/testing/pgbouncer/APKBUILD
+++ /dev/null
@@ -1,60 +0,0 @@
-# Contributor: Francesco Colista <fcolista@alpinelinux.org>
-# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
-pkgname=pgbouncer
-pkgver=1.7.2
-pkgrel=2
-pkgdesc="A lightweight connection pooler for PostgreSQL"
-url="https://wiki.postgresql.org/wiki/PgBouncer"
-arch="all"
-license="BSD"
-pkgusers="pgbouncer"
-pkggroups="postgres"
-install="$pkgname.pre-install"
-makedepends="c-ares-dev libevent-dev libressl-dev udns-dev"
-subpackages="$pkgname-doc"
-source="https://pgbouncer.github.io/downloads/files/$pkgver/$pkgname-$pkgver.tar.gz
- $pkgname.initd
- $pkgname.confd
- $pkgname.logrotate
- pgbouncer-dirs.patch
- libressl-2.5.patch
- "
-builddir="$srcdir/$pkgname-$pkgver"
-
-build() {
- cd "$builddir"
-
- ./configure \
- --prefix=/usr \
- --disable-debug
- make
-}
-
-check() {
- cd "$builddir"
-
- ./pgbouncer --version
- make -C test
-}
-
-package() {
- cd "$builddir"
-
- make DESTDIR="$pkgdir" install
-
- cd "$pkgdir"
-
- install -m 755 -D "$srcdir"/$pkgname.initd ./etc/init.d/$pkgname
- install -m 644 -D "$srcdir"/$pkgname.confd ./etc/conf.d/$pkgname
- install -m 644 -D "$srcdir"/$pkgname.logrotate ./etc/logrotate.d/$pkgname
- install -m 644 -D "$builddir"/etc/$pkgname.ini ./etc/$pkgname/$pkgname.ini
-
- install -d -m 755 -o $pkgusers -g $pkggroups ./var/log/$pkgname
-}
-
-sha512sums="11c89606599f424b34f39a4b072ec6293fea0b14ee52ae4fbc44775e6d83771a22d194f4e8eabe410e0d6a70657508cf1a3b1012543d91873c36f644afb5675d pgbouncer-1.7.2.tar.gz
-a6dbfa477c2f0a405e4bf9ee0037165531802366565d0f192931ccd8a7cb3edf9e9b628655e4169592e9370cc71fb73d4424bfd3f20bb5a43eb26a52251e539d pgbouncer.initd
-808621351b0f5973427fa22f63128432b00ac20fd25af437e8148dad9e55185775aba612b6ecdd58e4a6f2450b8c7838fcace288845b9b3cd0236bbe168aa574 pgbouncer.confd
-83b869466b59c1b1d6e316a9368f725181128c1f5a7af230e3fa9c58ccda1bc097db182806c1c51a5121692791ec83d9eb0f5718fb3031f521bb537001153e2d pgbouncer.logrotate
-fdee368ce422960ebc06547765a7e5eabc59d10ae8730948be1c5f9083adcac3aa373f41fd9972d1b9ef635a062f1e021d787085a5beb5d80edf4203f284c7c4 pgbouncer-dirs.patch
-97caf142578f2f9d1500979ce88244554f316f999837707137dc4c3ec6ebc45bcef16678e61fdd1118bf4e26c7df733bd399f4a82b9b5a8e44c3497ab0922524 libressl-2.5.patch"