aboutsummaryrefslogtreecommitdiffstats
path: root/testing/php-blenc
diff options
context:
space:
mode:
Diffstat (limited to 'testing/php-blenc')
-rw-r--r--testing/php-blenc/APKBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/testing/php-blenc/APKBUILD b/testing/php-blenc/APKBUILD
new file mode 100644
index 0000000000..02ebdd0e13
--- /dev/null
+++ b/testing/php-blenc/APKBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Diaz Devera Victor <vitronic2@gmail.com>
+
+pkgname=php-blenc
+pkgver=1.1.4b
+pkgrel=0
+pkgdesc="BLowfish ENCryption for PHP Scripts"
+url="http://pecl.php.net/package/blenc"
+arch="all"
+license="PHP"
+depends=
+depends_dev="php-dev"
+makedepends="$depends_dev autoconf"
+install=""
+subpackages=""
+source="http://pecl.php.net/get/blenc-$pkgver.tgz"
+
+_builddir="$srcdir/blenc-$pkgver"
+
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ phpize || return 1
+ ./configure --prefix=/usr || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make INSTALL_ROOT="$pkgdir/" install || return 1
+ install -d "$pkgdir"/etc/php/conf.d || return 1
+ echo "extension=blenc.so" > "$pkgdir"/etc/php/conf.d/blenc.ini
+}
+
+md5sums="90ab57bf63854f7927ae66c2b3a40a7d blenc-1.1.4b.tgz"
+sha256sums="9f366346b0f1f76aa0e3d301fbe2b65de4dff291560a9a3a89f52a592ed0eaf0 blenc-1.1.4b.tgz"
+sha512sums="308011ae8ae3532e9bf6467bb90fe3fc26dfe9b49b10f76f9137e7529ca8b5040ebd750a87b221667db3cd180af5e11e517484fa43eaa5371e17ad0a96332c25 blenc-1.1.4b.tgz"