aboutsummaryrefslogtreecommitdiffstats
path: root/testing/php7-msgpack/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/php7-msgpack/APKBUILD')
-rw-r--r--testing/php7-msgpack/APKBUILD26
1 files changed, 18 insertions, 8 deletions
diff --git a/testing/php7-msgpack/APKBUILD b/testing/php7-msgpack/APKBUILD
index 67e971e8a4..5f53f1f98d 100644
--- a/testing/php7-msgpack/APKBUILD
+++ b/testing/php7-msgpack/APKBUILD
@@ -3,15 +3,17 @@
pkgname=php7-msgpack
_pkgreal=msgpack
pkgver=2.0.3
-pkgrel=0
-pkgdesc="This extension provide API for communicating with MessagePack serialization."
-url="https://pecl.php.net/package/$_pkgreal"
+pkgrel=1
+pkgdesc="PHP extension provides API for communicating with MessagePack serialization - PECL"
+url="https://pecl.php.net/package/msgpack"
arch="all"
license="PHP"
-options="!check" # Tests fail - does not load msgpack.so
-depends="php7-session"
-makedepends="php7-dev autoconf"
-source="https://pecl.php.net/get/$_pkgreal-$pkgver.tgz"
+depends="php7-session php7-sockets"
+makedepends="php7-dev autoconf re2c"
+source="https://pecl.php.net/get/$_pkgreal-$pkgver.tgz
+ 7c1eb7f70b82bcf611bebc9a9cfd88d5832443a1.patch
+ "
+# Patch skips broken tests https://github.com/msgpack/msgpack-php/issues/123
builddir="$srcdir"/$_pkgreal-$pkgver
build() {
@@ -21,6 +23,13 @@ build() {
make
}
+check() {
+ cd "$builddir"
+ # Tests require session and sockets extensions which are not bundled
+ sed -i 's#PHP_TEST_SHARED_EXTENSIONS = `#PHP_TEST_SHARED_EXTENSIONS = -d extension=/usr/lib/php7/modules/session.so -d extension=/usr/lib/php7/modules/sockets.so `#' Makefile
+ make NO_INTERACTION=1 REPORT_EXIT_STATUS=1 test
+}
+
package() {
cd "$builddir"
make INSTALL_ROOT="$pkgdir"/ install
@@ -28,4 +37,5 @@ package() {
echo "extension=$_pkgreal.so" > "$pkgdir"/etc/php7/conf.d/50_$_pkgreal.ini
}
-sha512sums="4eaf5d2cd50796349414d8272e210f1c8c2e82d72383f440e13d31742a75b0e2fa1f48bd916c057b4c65778bd90eace7dcc0cdb86931620963e666f3aa6905db msgpack-2.0.3.tgz"
+sha512sums="4eaf5d2cd50796349414d8272e210f1c8c2e82d72383f440e13d31742a75b0e2fa1f48bd916c057b4c65778bd90eace7dcc0cdb86931620963e666f3aa6905db msgpack-2.0.3.tgz
+ae8c505b64631e310020f3addf561a0c5855ebed07eaa0e4c1155dbd77a6e25a2e824d87684298d91f021cf8d028b88a6883f26c21cbea40d8acf46332dd2ce9 7c1eb7f70b82bcf611bebc9a9cfd88d5832443a1.patch"