aboutsummaryrefslogtreecommitdiffstats
path: root/testing/php7-pecl-protobuf
diff options
context:
space:
mode:
Diffstat (limited to 'testing/php7-pecl-protobuf')
-rw-r--r--testing/php7-pecl-protobuf/APKBUILD37
1 files changed, 0 insertions, 37 deletions
diff --git a/testing/php7-pecl-protobuf/APKBUILD b/testing/php7-pecl-protobuf/APKBUILD
deleted file mode 100644
index f07dd8f3c6..0000000000
--- a/testing/php7-pecl-protobuf/APKBUILD
+++ /dev/null
@@ -1,37 +0,0 @@
-# Contributor: TBK <alpine@jjtc.eu>
-# Maintainer: TBK <alpine@jjtc.eu>
-pkgname=php7-pecl-protobuf
-_pkgreal=protobuf
-pkgver=3.7.1
-pkgrel=0
-pkgdesc="PHP7 extension: Google's language-neutral, platform-neutral, extensible mechanism for serializing structured data."
-url="https://pecl.php.net/package/protobuf"
-arch="all"
-license="BSD-3-Clause"
-depends="php7-common"
-makedepends="php7-dev autoconf libtool"
-source="https://pecl.php.net/get/$_pkgreal-$pkgver.tgz"
-builddir="$srcdir/$_pkgreal-$pkgver"
-provides="php7-protobuf=$pkgver-r$pkgrel" # for backward compatibility
-replaces="php7-protobuf" # for backward compatibility
-
-build() {
- cd "$builddir"
- phpize7
- ./configure --prefix=/usr --with-php-config=php-config7
- make
-}
-
-check() {
- # Test suite is not a part of pecl release.
- php7 -d extension="$builddir"/modules/$_pkgreal.so --ri $_pkgreal
-}
-
-package() {
- cd "$builddir"
- make INSTALL_ROOT="$pkgdir" install
- install -d "$pkgdir"/etc/php7/conf.d
- echo "extension=$_pkgreal.so" > "$pkgdir"/etc/php7/conf.d/$_pkgreal.ini
-}
-
-sha512sums="bf35c4165e0440b26f32c73befa3b2827a07a33ab37d9d5c51f0f66836f6115c05a6163e90bd8d528196d5383bee51c9ecaf96d70f4ebd53fe93db40566350e3 protobuf-3.7.1.tgz"