aboutsummaryrefslogtreecommitdiffstats
path: root/testing/php7-pecl-vips/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/php7-pecl-vips/APKBUILD')
-rw-r--r--testing/php7-pecl-vips/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/testing/php7-pecl-vips/APKBUILD b/testing/php7-pecl-vips/APKBUILD
new file mode 100644
index 0000000000..efbce0bf8b
--- /dev/null
+++ b/testing/php7-pecl-vips/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: TBK <alpine@jjtc.eu>
+# Maintainer: TBK <alpine@jjtc.eu>
+pkgname=php7-pecl-vips
+_pkgname=vips
+pkgver=1.0.9
+pkgrel=0
+pkgdesc="PHP extension for interfacing with vips - PECL"
+url="https://pecl.php.net/package/vips"
+arch="all"
+license="MIT"
+depends="php7-common vips"
+makedepends="php7-dev autoconf vips-dev"
+source="$pkgname-$pkgver.tgz::https://pecl.php.net/get/$_pkgname-$pkgver.tgz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ phpize7
+ ./configure --prefix=/usr --with-php-config=php-config7
+ make
+}
+
+check() {
+ make NO_INTERACTION=1 REPORT_EXIT_STATUS=1 SKIP_ONLINE_TESTS=1 test
+}
+
+package() {
+ make INSTALL_ROOT="$pkgdir" install
+
+ install -d "$pkgdir"/etc/php7/conf.d
+ echo "extension=$_pkgname.so" > "$pkgdir"/etc/php7/conf.d/$_pkgname.ini
+}
+
+sha512sums="cdc9cc7aa7b0f88288003a6c24f1fb036490bb477354160e55b8bc5fc7a290558c32dd94ee7d5fb46f5a686742e0e292818c4e74b9fae17bac763e4e28db3f79 php7-pecl-vips-1.0.9.tgz"