aboutsummaryrefslogtreecommitdiffstats
path: root/testing/plasma
diff options
context:
space:
mode:
Diffstat (limited to 'testing/plasma')
-rw-r--r--testing/plasma/APKBUILD37
-rw-r--r--testing/plasma/sddm.conf3
2 files changed, 40 insertions, 0 deletions
diff --git a/testing/plasma/APKBUILD b/testing/plasma/APKBUILD
new file mode 100644
index 0000000000..c55a09969d
--- /dev/null
+++ b/testing/plasma/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=plasma
+pkgver=5.16.1
+pkgrel=0
+pkgdesc="Plasma (Base) meta package"
+url="https://kde.org/plasma-desktop"
+arch="noarch"
+options="!check" # No tests for a metapkg
+license="GPL-3.0-or-later"
+depends="
+ plasma-desktop
+ breeze
+ breeze-gtk
+ breeze-icons
+ systemsettings
+ sddm-breeze
+ sddm-kcm
+ plasma-pa
+ plasma-nm
+ kde-gtk-config
+ user-manager
+"
+subpackages="sddm-breeze:sddm_breeze"
+source="sddm.conf"
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+sddm_breeze() {
+ description="Set Breeze theme for SDDM"
+ depends="breeze sddm plasma-workspace"
+
+ install -Dm644 "$srcdir"/sddm.conf "$subpkgdir"/etc/sddm.conf
+}
+sha512sums="affbeec6d236bf09ae95b7bf478015ead9b5eabcffa8291107e34463bc3f7563c01d4e444e035b7eb575700e64c4da9f5079950b254b8c24b305845f031eb17f sddm.conf"
diff --git a/testing/plasma/sddm.conf b/testing/plasma/sddm.conf
new file mode 100644
index 0000000000..e5752799ab
--- /dev/null
+++ b/testing/plasma/sddm.conf
@@ -0,0 +1,3 @@
+[Theme]
+Current=breeze
+CursorTheme=breeze_cursors