aboutsummaryrefslogtreecommitdiffstats
path: root/testing/polipo
diff options
context:
space:
mode:
Diffstat (limited to 'testing/polipo')
-rw-r--r--testing/polipo/APKBUILD30
-rw-r--r--testing/polipo/polipo.initd16
2 files changed, 46 insertions, 0 deletions
diff --git a/testing/polipo/APKBUILD b/testing/polipo/APKBUILD
new file mode 100644
index 0000000000..b2461d517b
--- /dev/null
+++ b/testing/polipo/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Alexander Georgievskiy <galeksandrp@gmail.com>
+# Maintainer:
+pkgname=polipo
+pkgver=1.1.1
+pkgrel=0
+pkgdesc="The Polipo caching HTTP proxy"
+url="https://github.com/jech/$pkgname"
+arch="all"
+license="MIT"
+depends=""
+makedepends="texinfo"
+install=""
+subpackages="$pkgname-doc"
+source="https://github.com/jech/$pkgname/archive/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgname-$pkgver"
+options="!check"
+
+build() {
+ cd "$builddir"
+
+ make
+}
+
+package() {
+ cd "$builddir"
+
+ make PREFIX="$pkgdir/usr" MANDIR="$pkgdir/usr/share/man" INFODIR="$pkgdir/usr/share/info" LOCAL_ROOT="$pkgdir/usr/share/polipo/www" install
+}
+
+sha512sums="f99f4f7bbd39f2651a1df12e1c88d45938ddbc85ef10e2ce0e8a40e25019986a17e7cd449efcc0a268367297bc9597d935df2d1e4f48661cc8f28310a17b6327 polipo-1.1.1.tar.gz"
diff --git a/testing/polipo/polipo.initd b/testing/polipo/polipo.initd
new file mode 100644
index 0000000000..276d9315dc
--- /dev/null
+++ b/testing/polipo/polipo.initd
@@ -0,0 +1,16 @@
+#!/sbin/openrc-run
+depend() {
+ use net
+}
+
+start() {
+ ebegin "Starting polipo"
+ start-stop-daemon --start --background --pidfile /var/run/polipo.pid --make-pidfile --exec /usr/bin/polipo
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping polipo"
+ start-stop-daemon --stop --pidfile /var/run/polipo.pid
+ eend $?
+}