aboutsummaryrefslogtreecommitdiffstats
path: root/testing/postfwd/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/postfwd/APKBUILD')
-rw-r--r--testing/postfwd/APKBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/testing/postfwd/APKBUILD b/testing/postfwd/APKBUILD
new file mode 100644
index 0000000000..a68cca55a6
--- /dev/null
+++ b/testing/postfwd/APKBUILD
@@ -0,0 +1,47 @@
+# Contributor: Simon Frankenberger <simon-alpine@fraho.eu>
+# Maintainer: Simon Frankenberger <simon-alpine@fraho.eu>
+pkgname=postfwd
+pkgver=1.39
+pkgrel=0
+pkgdesc="Combines complex postfix restrictions in a ruleset similar to those of the most firewalls"
+url="https://postfwd.org/"
+arch="noarch"
+license="BSD"
+depends="perl-net-server perl-net-dns perl-io-multiplex"
+subpackages="$pkgname-doc $pkgname-openrc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/$pkgname/$pkgname/archive/v$pkgver.tar.gz
+ ${pkgname}2.initd
+ ${pkgname}2.confd
+ "
+options="!check" # package has no tests
+builddir="$srcdir/$pkgname-$pkgver"
+pkgusers="postfwd"
+pkggroups="postfwd"
+install="$pkgname.pre-install"
+provides="postfwd2=$pkgver-r$pkgrel" # for backward compatibility
+replaces="postfwd2" # for backward compatibility
+
+build() {
+ cd "$builddir"
+ # just print out version to check if all dependencies are met
+ sbin/postfwd2 -V
+}
+
+package() {
+ cd "$builddir"
+ mkdir -p "$pkgdir"/usr/sbin \
+ "$pkgdir"/usr/share/doc/postfwd2 \
+ "$pkgdir"/usr/share/man/man8 \
+ "$pkgdir"/etc/postfwd2 \
+ "$pkgdir"/etc/init.d
+ install -m0755 sbin/postfwd2 "$pkgdir"/usr/sbin
+ install -m0644 doc/* "$pkgdir"/usr/share/doc/postfwd2
+ install -m0644 man/man8/* "$pkgdir"/usr/share/man/man8
+ install -m0644 etc/postfwd.cf.sample "$pkgdir"/etc/postfwd2
+ install -Dm755 "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
+ install -Dm644 "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
+}
+
+sha512sums="b292b3d5cb634fedc039b33225e5f3e5653a25e56b5b2d9a5936d0a9d59ddb9a0fef129221f23859a679609eed57f4c7f20299f4895a48600cc78d2e22756a16 postfwd-1.39.tar.gz
+b33ebb90d5e38f2af3cd93d0205672d83a618b253e22a6fc10cffee4b1e75513189f6214ae25a910913119c1ce0178fabdd95cc10c47ac1f85093953c4e04f5a postfwd2.initd
+e1ead4e130c593fabf6ce28fdbdf74806bd922556b492976c03b3578112c533ca60645ad11786785763abf6dd94fee37f2e7261661314f712f9f46fad2acd20d postfwd2.confd"