aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-ansible-lint/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py-ansible-lint/APKBUILD')
-rw-r--r--testing/py-ansible-lint/APKBUILD48
1 files changed, 48 insertions, 0 deletions
diff --git a/testing/py-ansible-lint/APKBUILD b/testing/py-ansible-lint/APKBUILD
new file mode 100644
index 0000000000..2f14873e71
--- /dev/null
+++ b/testing/py-ansible-lint/APKBUILD
@@ -0,0 +1,48 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-ansible-lint
+_pkgname=ansible-lint
+pkgver=3.4.12
+pkgrel=0
+pkgdesc="A tool to check ansible playbooks"
+url="https://github.com/willthames/ansible-lint"
+arch="noarch"
+license="MIT"
+depends="ansible"
+makedepends="python2-dev python3-dev py-setuptools"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python2 setup.py build || return 1
+ python3 setup.py build || return 1
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ depends="${depends//py-/py2-}"
+ _py python2
+}
+
+_py3() {
+ depends="${depends//py-/py3-}"
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+sha512sums="8b4021fa64aab4938de9003d62fde258b95c6a47451042ad54816dd905c24c4aaf52d352fd6a2536a3a083b1560c3b98bbf2bb6d6636053a76f41c14f8b63f1f ansible-lint-3.4.12.tar.gz"