aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-country
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py-country')
-rw-r--r--testing/py-country/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/testing/py-country/APKBUILD b/testing/py-country/APKBUILD
new file mode 100644
index 0000000000..cb82b2bc0f
--- /dev/null
+++ b/testing/py-country/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Kaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>
+# Maintainer:
+pkgname=py-country
+pkgver=1.10
+pkgrel=0
+pkgdesc="ISO country, subdivision, language, currency and script definitions and their translations"
+url=https://pypi.python.org/pypi/pycountry
+arch=noarch
+license=LGPL2.1
+depends=
+makedepends=py-setuptools
+source=https://pypi.python.org/packages/source/p/pycountry/pycountry-$pkgver.zip
+
+_builddir=$srcdir/pycountry-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --root "$pkgdir"
+}
+
+md5sums="617635a7e94dc3d18ebcb5382cd3c93f pycountry-1.10.zip"
+sha256sums="29bd07e5f0d0471c260cea14e2ca4b7d705228ebb024b4de139dc87795576e67 pycountry-1.10.zip"
+sha512sums="076de329c5b9d7626fbf0aace654504a2cd2d1d7bdf2ec89ba4763b38b756a6e75c7f3032c4b8785693d291ace7a206673cac1a457c4dd59e8c3ce1cd70d7d60 pycountry-1.10.zip"