aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-distro
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py-distro')
-rw-r--r--testing/py-distro/APKBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/testing/py-distro/APKBUILD b/testing/py-distro/APKBUILD
index a1844f2ef1..b75a0f3032 100644
--- a/testing/py-distro/APKBUILD
+++ b/testing/py-distro/APKBUILD
@@ -9,14 +9,21 @@ url="https://github.com/nir0s/distro"
arch="noarch"
license="MIT"
makedepends="python2-dev py-setuptools python3-dev"
+options="!check" # tox is not available
+#checkdepends="py3-tox"
subpackages="py3-$_pkgname:_py3 py2-$_pkgname:_py2"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
build() {
cd "$builddir"
- python2 setup.py build || return 1
- python3 setup.py build || return 1
+ python2 setup.py build
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ tox
}
package() {