aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-gevent
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py-gevent')
-rw-r--r--testing/py-gevent/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/testing/py-gevent/APKBUILD b/testing/py-gevent/APKBUILD
new file mode 100644
index 0000000000..7cf3309200
--- /dev/null
+++ b/testing/py-gevent/APKBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Michael Zhou <zhoumichaely@gmail.com>
+# Contributor: Michael Zhou <zhoumichaely@gmail.com>
+pkgname=py-gevent
+pkgver=0.13.5
+pkgrel=0
+pkgdesc="Python library for seamless coroutine-based concurrency"
+url="http://gevent.org/"
+arch="x86 x86_64"
+license="MIT"
+depends="python py-greenlet libevent"
+makedepends="python-dev py-setuptools libevent-dev"
+source="http://pypi.python.org/packages/source/g/gevent/gevent-${pkgver}.tar.gz"
+
+_builddir="$srcdir"/gevent-$pkgver
+build ()
+{
+ cd "$_builddir"
+ python setup.py build
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --root="$pkgdir"
+}
+md5sums="8143d708256eec0579fb65d76ab0b05c gevent-0.13.5.tar.gz"