aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-jedi/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py-jedi/APKBUILD')
-rw-r--r--testing/py-jedi/APKBUILD33
1 files changed, 0 insertions, 33 deletions
diff --git a/testing/py-jedi/APKBUILD b/testing/py-jedi/APKBUILD
deleted file mode 100644
index b649c4489b..0000000000
--- a/testing/py-jedi/APKBUILD
+++ /dev/null
@@ -1,33 +0,0 @@
-# Contributor: Francesco Colista <fcolista@alpinelinux.org>
-# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
-pkgname=py-jedi
-_pkgname=jedi
-pkgver=0.13.3
-pkgrel=0
-pkgdesc="Awesome autocompletion and static analysis library for python"
-url="https://pypi.org/project/jedi"
-arch="noarch"
-license="MIT"
-makedepends="py3-setuptools python3-dev"
-checkdepends="pytest py-parso py-tox"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-builddir="$srcdir"/$_pkgname-$pkgver
-replaces="py3-jedi"
-
-build() {
- python3 setup.py build
-}
-
-_getpythonver(){
- echo $(python3 -c 'import sys; print("{}{}".format(sys.version_info.major, sys.version_info.minor))')
-}
-
-check() {
- tox -e py$(_getpythonver)
-}
-
-package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
-}
-
-sha512sums="b20fc75d909f9b7c6db434f468e7cefd9768991ca72d7026df9c4000805675a979f9e40f75623770df44bf8919a46270bcaa8e28d991a2299c64bc4c60d873fc jedi-0.13.3.tar.gz"