aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-pies
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py-pies')
-rw-r--r--testing/py-pies/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/testing/py-pies/APKBUILD b/testing/py-pies/APKBUILD
new file mode 100644
index 0000000000..2478e504b4
--- /dev/null
+++ b/testing/py-pies/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-pies
+_pkgname=pies
+pkgver=2.5.5
+pkgrel=0
+pkgdesc="A tool that support you to write tool for Python 2.6-3.x"
+url="https://github.com/timothycrosley/pies"
+arch="noarch"
+license="MIT"
+depends="python"
+depends_dev=""
+makedepends="python-dev"
+install=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="71d4d85edbb289afc1b34f49f505b726 pies-2.5.5.tar.gz"
+sha256sums="35de200a5a65446d6d6eeb8d8dce4b87c5e31ab517864cc6b01bbda15f3da3bb pies-2.5.5.tar.gz"
+sha512sums="b6f04d44a459e3c0c5bffef0237586f264f89ac3d82d1d71ea0206644d2bdeb08417158b7dbfe1cf9b0ac5a7d4d5e4d2df521022dd4997b43ee967a4f3f6040f pies-2.5.5.tar.gz"