aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-traceback2
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py-traceback2')
-rw-r--r--testing/py-traceback2/APKBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/testing/py-traceback2/APKBUILD b/testing/py-traceback2/APKBUILD
index 333e094da6..d4813784fb 100644
--- a/testing/py-traceback2/APKBUILD
+++ b/testing/py-traceback2/APKBUILD
@@ -3,12 +3,12 @@
pkgname=py-traceback2
_pkgname=${pkgname#py-*}
pkgver=1.4.0
-pkgrel=0
+pkgrel=1
pkgdesc="Backport of the Python3 stdlib traceback module"
url="https://github.com/testing-cabal/traceback2"
arch="noarch"
license="PSF"
-makedepends="python2-dev python3-dev py-setuptools"
+makedepends="python2-dev python3-dev py-setuptools py-pbr"
subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
options="!check" # temp disable until py2-unittest2 is in repos
#checkdepends="py2-contextlib2 py-fixtures py-testtools py2-unittest2 py2-linecache2 py-extras"
@@ -17,6 +17,8 @@ builddir="$srcdir/$_pkgname-$pkgver"
build() {
cd "$builddir"
+ git init # workaround python pbr picking up the git version from aports
+
python2 setup.py build
python3 setup.py build
}