aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-zmq/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py-zmq/APKBUILD')
-rw-r--r--testing/py-zmq/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/py-zmq/APKBUILD b/testing/py-zmq/APKBUILD
new file mode 100644
index 0000000000..c5426615ae
--- /dev/null
+++ b/testing/py-zmq/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-zmq
+_pkgname=pyzmq
+pkgver=2.2.0
+pkgrel=0
+pkgdesc="Python bindings for ZeroMQ"
+url="http://pypi.python.org/pypi/pyzmq"
+arch="all"
+license="LGPL BSD"
+depends=""
+depends_dev=""
+makedepends="python-dev py-setuptools zeromq-dev"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/p/$_pkgname/$_pkgname-$pkgver.tar.gz"
+_builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="100b73973d6fb235b8da6adea403566e pyzmq-2.2.0.tar.gz"