aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-bottle-hotqueue/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-bottle-hotqueue/APKBUILD')
-rw-r--r--testing/py3-bottle-hotqueue/APKBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/testing/py3-bottle-hotqueue/APKBUILD b/testing/py3-bottle-hotqueue/APKBUILD
new file mode 100644
index 0000000000..9492b54684
--- /dev/null
+++ b/testing/py3-bottle-hotqueue/APKBUILD
@@ -0,0 +1,47 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-bottle-hotqueue
+_pkgname=bottle-hotqueue
+pkgver=0.2.5
+pkgrel=1
+pkgdesc="Bottle HotQueue plugin"
+url="https://github.com/waawal/bottle_hotqueue"
+arch="noarch !armv7"
+license="MIT"
+depends="py-bottle py-hotqueue"
+makedepends="py-setuptools py3-setuptools"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ python2 setup.py build
+ python3 setup.py build
+}
+
+package() {
+ python2 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ _py python2
+}
+
+_py3() {
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+sha512sums="0ee8a1254d3997b7066443100a27de5ca22b31f4c24bd2bc92bb41fa296516a9096d170e1d48b30dea192fe424b3d9b487b851c6a4c272c0c4a55681a1afc2dc bottle-hotqueue-0.2.5.tar.gz"