aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-bottle-sqlite/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-bottle-sqlite/APKBUILD')
-rw-r--r--testing/py3-bottle-sqlite/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/testing/py3-bottle-sqlite/APKBUILD b/testing/py3-bottle-sqlite/APKBUILD
new file mode 100644
index 0000000000..971a7e18e5
--- /dev/null
+++ b/testing/py3-bottle-sqlite/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-bottle-sqlite
+_pkgname=bottle-sqlite
+pkgver=0.1.3
+pkgrel=0
+pkgdesc="Bottle sqlite plugin"
+url="https://pypi.python.org/pypi/bottle-sqlite"
+arch="noarch"
+license="MIT"
+depends="python2 py-bottle"
+makedepends="python2-dev py-setuptools"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+}
+
+package() {
+ cd "$builddir"
+ python2 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="670f44bdb8d6c62205b264abcc03c8bbbd7ae34c85dbaaa0ad2c6f6902ea590035190f86ba24366ca2b4befe5488592278d31074dfdc2c897d9ad1bfc7e0a9e9 bottle-sqlite-0.1.3.tar.gz"