aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-dill/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-dill/APKBUILD')
-rw-r--r--testing/py3-dill/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/testing/py3-dill/APKBUILD b/testing/py3-dill/APKBUILD
new file mode 100644
index 0000000000..160253471e
--- /dev/null
+++ b/testing/py3-dill/APKBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Drew DeVault <sir@cmpwn.com>
+pkgname=py3-dill
+_pyname=dill
+pkgver=0.2.9
+pkgrel=0
+pkgdesc="Python serializer supporting a broader range of types than pickle"
+url="https://pypi.org/projects/dill/"
+arch="noarch"
+license="BSD-3-Clause"
+makedepends="python3 py3-setuptools"
+_pypiprefix="${_pyname%${_pyname#?}}"
+source="https://files.pythonhosted.org/packages/source/$_pypiprefix/$_pyname/$_pyname-$pkgver.tar.gz"
+builddir=$srcdir/$_pyname-$pkgver
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ export PYTHONPATH="$(pwd):$PYTHONPATH"
+ for t in tests/*.py
+ do
+ echo "$t"
+ python3 "$t"
+ done
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="b395f59a4f45cda0eb82a4ea4da03232a645daeba988b4578f8d62ef3de2b755d04cee53caa19a17ca35b64802312ec92b7d64066b494c4f954a28edcdd7742c dill-0.2.9.tar.gz"