aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-dulwich/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-dulwich/APKBUILD')
-rw-r--r--testing/py3-dulwich/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/testing/py3-dulwich/APKBUILD b/testing/py3-dulwich/APKBUILD
new file mode 100644
index 0000000000..f081912f16
--- /dev/null
+++ b/testing/py3-dulwich/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py3-dulwich
+_pkgname=dulwich
+pkgver=0.19.10
+pkgrel=1
+pkgdesc="A python implementation of the Git file formats and protocols"
+url="https://www.dulwich.io"
+arch="all"
+license="GPL-2.0-or-later or Apache-2.0"
+options="!check" # Tests are failing (http-backend)
+makedepends="py3-setuptools python3-dev"
+source="https://github.com/dulwich/dulwich/archive/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-dulwich-$pkgver
+
+replaces="py-dulwich" # Backwards compatibility
+provides="py-dulwich=$pkgver-r$pkgrel" # Backwards compatibility
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+#check() {
+# cd "$builddir"
+# PYTHONHASHSEED=random PYTHONPATH=.: python -m unittest dulwich.tests.test_suite
+# PYTHONHASHSEED=random PYTHONPATH=.: python3 -m unittest dulwich.tests.test_suite
+#}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+sha512sums="0699e7cdea103f2caca24b7841d2cb761d264d3847c22ceb74b5c3f9a890ad8143dad5affd339da424b38c1b13e55788b2d521797b9653a7ff7c373ab02b2401 dulwich-0.19.10.tar.gz"