aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-favicon
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-favicon')
-rw-r--r--testing/py3-favicon/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/py3-favicon/APKBUILD b/testing/py3-favicon/APKBUILD
new file mode 100644
index 0000000000..6bd05e3330
--- /dev/null
+++ b/testing/py3-favicon/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+pkgname=py3-favicon
+pkgver=0.1.1
+pkgrel=0
+pkgdesc="Async favicon fetcher for Python3"
+url="https://github.com/bilelmoussaoui/pyfavicon"
+arch="noarch"
+license="MIT"
+depends="py3-aiohttp py3-pillow py3-beautifulsoup4 py3-idna"
+makedepends="python3-dev py3-setuptools"
+checkdepends="py3-pytest-cov py3-coveralls"
+options="!check" # Test module can't be found
+source="https://pypi.io/packages/source/p/pyfavicon/pyfavicon-$pkgver.tar.gz"
+builddir="$srcdir/pyfavicon-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="c9f9bf27e2eebb553a1ae53a69a03d3427ca147e217179703d3c316e78c68157b31c8fcc0a98c21ee38c4739ba82b91f1167560b82f908d58b123d0090d60274 pyfavicon-0.1.1.tar.gz"