aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-fido2
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-fido2')
-rw-r--r--testing/py3-fido2/APKBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/testing/py3-fido2/APKBUILD b/testing/py3-fido2/APKBUILD
index 7d3d2aee64..487f741218 100644
--- a/testing/py3-fido2/APKBUILD
+++ b/testing/py3-fido2/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Daniel Everett <deverett@gmail.com>
pkgname=py3-fido2
_pkgname=${pkgname#py3-}
-pkgver=0.7.0
+pkgver=0.7.1
pkgrel=0
pkgdesc="Provides library functionality for FIDO 2.0, including communication with a device over USB"
url="https://developers.yubico.com/python-fido2/"
@@ -10,6 +10,7 @@ arch="noarch"
license="BSD-2-Clause AND Apache-2.0 AND MPL-2.0"
depends="py3-cryptography py3-six"
makedepends="py3-setuptools"
+checkdepends="py3-cparser py3-mock"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
@@ -22,8 +23,9 @@ package() {
}
check() {
+ # Requires downloading 'pyfakefs' module
touch "test/__init__.py"
python3 setup.py test
}
-sha512sums="65fdaeeb1932873fb2ae86257182eb6098d6bf4ce5ed45336327bd3e9040eddccd7f7559ece58d9bdcbfe8c98c2eb8646069556a6d00035fef5eade4907a45d8 fido2-0.7.0.tar.gz"
+sha512sums="07024a4076d88bd9ec5d5dbfd924c88e314906668444d96aa9177c373309e90e33c18fd5313943fd83eb28b6d40f0c16a8f64c5d9a2aa50f2fc5115c1967ae3a fido2-0.7.1.tar.gz"