aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-firmata/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-firmata/APKBUILD')
-rw-r--r--testing/py3-firmata/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/testing/py3-firmata/APKBUILD b/testing/py3-firmata/APKBUILD
new file mode 100644
index 0000000000..294a17e3c0
--- /dev/null
+++ b/testing/py3-firmata/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py3-firmata
+_pkgname=pyFirmata
+pkgver=1.0.3
+pkgrel=1
+pkgdesc="Python interface for the Firmata procotol"
+url="https://github.com/tino/pyFirmata"
+arch="noarch"
+license="MIT"
+depends="python3 py3-serial"
+depends_dev=""
+makedepends="py3-setuptools"
+install=""
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+options="!check" # upstream provides no testsuite
+
+_builddir="$srcdir/$_pkgname-$pkgver"
+
+replaces=py-firmata # Backwards compatibility
+provides=py-firmata=$pkgver-r$pkgrel # Backwards compatibility
+
+build() {
+ cd "$_builddir"
+ python3 setup.py build
+}
+
+package() {
+ cd "$_builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="9a5986d417447503c39e0497881592cecc38b423c55a627a38b398952cec7469e143ecbf1a82f9cd20ad93c7956ec06553f28e708419f05bb3c1d120961aa1b9 pyFirmata-1.0.3.tar.gz"