aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-gitpython
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-gitpython')
-rw-r--r--testing/py3-gitpython/APKBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/testing/py3-gitpython/APKBUILD b/testing/py3-gitpython/APKBUILD
index 9bbf40d58c..b6e57ce41a 100644
--- a/testing/py3-gitpython/APKBUILD
+++ b/testing/py3-gitpython/APKBUILD
@@ -4,12 +4,13 @@ pkgname=py3-gitpython
pkgver=3.0.2
pkgrel=0
pkgdesc="Python3 Git Library"
-options="!check" # Requires unpackaged 'ddt'
+options="!check" # Tests require a specific git configuration
url="https://github.com/gitpython-developers/GitPython"
arch="noarch"
license="BSD-3-Clause"
depends="python3 py3-gitdb2"
-makedepends="python3-dev py3-setuptools"
+makedepends="py3-setuptools"
+checkdepends="py3-ddt py3-nose"
source="$pkgname-$pkgver.tar.gz::https://github.com/gitpython-developers/GitPython/archive/$pkgver.tar.gz"
builddir="$srcdir/GitPython-$pkgver"
@@ -18,7 +19,7 @@ build() {
}
check() {
- python3 setup.py test
+ nosetests
}
package() {