aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-google-auth/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-google-auth/APKBUILD')
-rw-r--r--testing/py3-google-auth/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/testing/py3-google-auth/APKBUILD b/testing/py3-google-auth/APKBUILD
new file mode 100644
index 0000000000..dc3ef6baba
--- /dev/null
+++ b/testing/py3-google-auth/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Keith Maxwell <keith.maxwell@gmail.com>
+# Maintainer: Keith Maxwell <keith.maxwell@gmail.com>
+pkgname=py3-google-auth
+_pyname=google-auth
+pkgver=1.6.3
+pkgrel=0
+pkgdesc="Google authentication library for Python."
+url="https://google-auth.readthedocs.io/en/latest/"
+arch="noarch"
+license="Apache-2.0"
+depends="python3 py3-cachetools py3-asn1-modules py3-setuptools py3-rsa py3-six"
+checkdepends="py3-certifi py3-flask py3-oauth2client py3-pytest py3-pytest-cov
+ py3-pytest-localserver py3-requests py3-requests-oauthlib py3-urllib3
+ py3-cryptography"
+source="https://files.pythonhosted.org/packages/source/g/${_pyname}/${_pyname}-${pkgver}.tar.gz
+ 10-use-mock-from-standard-library.patch
+ "
+
+builddir="$srcdir/$_pyname-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+check() {
+ pytest-3 # skips grpc tests
+}
+
+sha512sums="47a3e9390428ffa58946c348d4e1a1bfe1290d6e06b75924bbacb37d5af929050690ef5c13820468de805646f4686c035b00dfe947c090d53568dd85d804af5e google-auth-1.6.3.tar.gz
+4242765bce157f7e3ba42b668396d7629b78a389f82832960b689741c0f30f6a1a3d07e217b37c6c6515813b6a7783e1cc9308046bc38d9fcb0c596bf3f896ff 10-use-mock-from-standard-library.patch"