aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-iniherit
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-iniherit')
-rw-r--r--testing/py3-iniherit/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/py3-iniherit/APKBUILD b/testing/py3-iniherit/APKBUILD
new file mode 100644
index 0000000000..3a636a7c4a
--- /dev/null
+++ b/testing/py3-iniherit/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+pkgname=py3-iniherit
+pkgver=0.3.9
+pkgrel=0
+pkgdesc="A ConfigParser subclass with file-specified inheritance"
+url="http://github.com/cadithealth/iniherit"
+arch="noarch"
+license="MIT"
+depends="py3-six"
+makedepends="python3-dev py3-setuptools"
+checkdepends="py3-nose py3-coverage"
+options="!check" # broken, recurse until they hit the recursion limit
+source="https://pypi.io/packages/source/i/iniherit/iniherit-$pkgver.tar.gz"
+builddir="$srcdir/iniherit-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="097e300c0066e9b035dd28dda87a392102e7f45130471e903e222bdaf209a154f92e08db22f4b6547bdbe25f1e5350e2cec4064b0ed7d86fbed0f0f623946c27 iniherit-0.3.9.tar.gz"