aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-ioflo/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-ioflo/APKBUILD')
-rw-r--r--testing/py3-ioflo/APKBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/testing/py3-ioflo/APKBUILD b/testing/py3-ioflo/APKBUILD
index d32cf88e04..27c0645bdc 100644
--- a/testing/py3-ioflo/APKBUILD
+++ b/testing/py3-ioflo/APKBUILD
@@ -8,20 +8,24 @@ pkgdesc="Automated Reasoning Engine and Flow Based Programming Framework"
url="https://github.com/ioflo/ioflo"
arch="noarch"
license="MIT"
-replaces="py-ioflo" # for backwards compatibility
-provides="py-ioflo=$pkgver-r$pkgrel" # for backwards compatibility
depends="python3"
makedepends="py3-setuptools-git"
+checkdepends="py3-pytest"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
+replaces="py-ioflo" # Backwards compatibility
+provides="py-ioflo=$pkgver-r$pkgrel" # Backwards compatibility
+
build() {
- cd "$builddir"
python3 setup.py build
}
+check() {
+ py.test-3
+}
+
package() {
- cd "$builddir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
# keep ioflo and remove ioflo3