aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-k5test/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-k5test/APKBUILD')
-rw-r--r--testing/py3-k5test/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/testing/py3-k5test/APKBUILD b/testing/py3-k5test/APKBUILD
new file mode 100644
index 0000000000..5df48cede0
--- /dev/null
+++ b/testing/py3-k5test/APKBUILD
@@ -0,0 +1,24 @@
+# Contributor: Dmitry Romanenko <dmitry@romanenko.in>
+# Maintainer: Dmitry Romanenko <dmitry@romanenko.in>
+pkgname=py3-k5test
+_pkgname=k5test
+pkgver=0.9.2
+pkgrel=0
+pkgdesc="A library for testing Python applications in self-contained Kerberos 5 environments"
+url="https://github.com/pythongssapi/k5test"
+arch="noarch"
+license="MIT"
+depends="python3 py-six krb5-dev"
+options="!check" # Package doesn't have tests
+source="https://files.pythonhosted.org/packages/source/k/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="fa32d5baf36cf76dd8cef09b7bb8d5c7ce363f80a4112aaf76b2196c7e1c3b8318d8f7f1fa5a1968f670611ea331366c7cae948c1695a2de9c0fbc25248eab16 k5test-0.9.2.tar.gz"