aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-maxminddb/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-maxminddb/APKBUILD')
-rw-r--r--testing/py3-maxminddb/APKBUILD10
1 files changed, 2 insertions, 8 deletions
diff --git a/testing/py3-maxminddb/APKBUILD b/testing/py3-maxminddb/APKBUILD
index 69ebbb241e..29ddaaa6da 100644
--- a/testing/py3-maxminddb/APKBUILD
+++ b/testing/py3-maxminddb/APKBUILD
@@ -8,7 +8,7 @@ url="http://maxminddb.readthedocs.org/"
arch="all"
license="Apache-2.0"
depends="python3"
-makedepends="libmaxminddb-dev python3 python3-dev py3-setuptools"
+makedepends="libmaxminddb-dev python3-dev py3-setuptools"
checkdepends="py3-nose py3-mock"
_test_data_commit=90c7fb95d67ee03ca7fc487fb69f525bcc19a671
source="$pkgname-$pkgver.tar.gz::https://github.com/maxmind/MaxMind-DB-Reader-python/archive/v$pkgver.tar.gz
@@ -22,24 +22,18 @@ prepare() {
# Submodule required for tests
cp -r "MaxMind-DB-$_test_data_commit/"* "$builddir/tests/data"
- default_prepare
+ default_prepare
}
build() {
- cd "$builddir"
-
python3 setup.py build
}
check() {
- cd "$builddir"
-
python3 setup.py test
}
package() {
- cd "$builddir"
-
python3 setup.py install --prefix=/usr --root="$pkgdir"
}