aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-pycountry
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-pycountry')
-rw-r--r--testing/py3-pycountry/APKBUILD11
1 files changed, 5 insertions, 6 deletions
diff --git a/testing/py3-pycountry/APKBUILD b/testing/py3-pycountry/APKBUILD
index 51a23caec5..b4cc543ede 100644
--- a/testing/py3-pycountry/APKBUILD
+++ b/testing/py3-pycountry/APKBUILD
@@ -3,25 +3,24 @@
pkgname=py3-pycountry
_pkgname=pycountry
pkgver=18.12.8
-pkgrel=1
+pkgrel=2
pkgdesc="ISO country, subdivision, language, currency and script definitions and their translations"
url="https://pypi.org/project/pycountry"
arch="noarch"
license="LGPL-2.1-or-later"
-provides="py-pycountry" # for backwards compatibility
-replaces="py-pycountry=$pkgver-r$pkgrel" # for backwards compatibility
depends="python3"
-makedepends="python3-dev py3-setuptools"
+makedepends="py3-setuptools"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
+replaces="py-pycountry" # for backwards compatibility
+provides="py-pycountry=$pkgver-r$pkgrel" # for backwards compatibility
+
build() {
- cd "$builddir"
python3 setup.py build
}
package() {
- cd "$builddir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
}