aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-pyhamcrest/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-pyhamcrest/APKBUILD')
-rw-r--r--testing/py3-pyhamcrest/APKBUILD13
1 files changed, 6 insertions, 7 deletions
diff --git a/testing/py3-pyhamcrest/APKBUILD b/testing/py3-pyhamcrest/APKBUILD
index 77e93b5248..36e1a07a9b 100644
--- a/testing/py3-pyhamcrest/APKBUILD
+++ b/testing/py3-pyhamcrest/APKBUILD
@@ -3,27 +3,27 @@
pkgname=py3-pyhamcrest
_pkgname=PyHamcrest
pkgver=1.9.0
-pkgrel=1
+pkgrel=2
pkgdesc="Hamcrest framework for matcher objects"
url="https://github.com/hamcrest/PyHamcrest"
arch="noarch"
license="BSD-3-Clause"
-replaces="py3-hamcrest"
-provides="py3-hamcrest=$pkgver-r$pkgrel"
-depends="py3-six python3"
-makedepends="py3-setuptools python3-dev"
+depends="py3-six"
+makedepends="py3-setuptools"
checkdepends="py3-hypothesis py3-mock py3-pytest"
source="$_pkgname-$pkgver.tar.gz::https://github.com/hamcrest/PyHamcrest/archive/V$pkgver.tar.gz
silence-warnings.patch"
builddir="$srcdir/"$_pkgname-$pkgver
+replaces="py3-hamcrest" # Backwards compatibility
+provides="py3-hamcrest=$pkgver-r$pkgrel" # Backwards compatibility
+
prepare() {
default_prepare
rm -f pytest.ini
}
build() {
- cd "$builddir"
python3 setup.py build
}
@@ -32,7 +32,6 @@ check() {
}
package() {
- cd "$builddir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
}