aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-pyramid-layout/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-pyramid-layout/APKBUILD')
-rw-r--r--testing/py3-pyramid-layout/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/py3-pyramid-layout/APKBUILD b/testing/py3-pyramid-layout/APKBUILD
new file mode 100644
index 0000000000..6087effa55
--- /dev/null
+++ b/testing/py3-pyramid-layout/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-pyramid-layout
+_pkgname=pyramid_layout
+pkgver=1.0
+pkgrel=0
+pkgdesc="A pyramid plugin that provides UI layout"
+url="https://pypi.python.org/pypi/pyramid_layout"
+arch="noarch"
+license="BSD"
+depends="python2 py-pyramid"
+makedepends="python2-dev py-setuptools"
+options="!check"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+}
+
+package() {
+ cd "$builddir"
+ python2 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="3cabb35cc0bb7a09f8b5b2ef439e689e3ab484bf73bb2664f4d250624dca601eada7204d894956bbc194a1da1977ded6d8d26c566f56fbde3c219adbfd7379be pyramid_layout-1.0.tar.gz"