aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-shellingham/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-shellingham/APKBUILD')
-rw-r--r--testing/py3-shellingham/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/py3-shellingham/APKBUILD b/testing/py3-shellingham/APKBUILD
new file mode 100644
index 0000000000..5034f01c6a
--- /dev/null
+++ b/testing/py3-shellingham/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=py3-shellingham
+_realname=shellingham
+pkgver=1.3.1
+pkgrel=0
+pkgdesc="Python3 module to poke around and find out running shell"
+options="!check" # Requires unpackaged dependencies
+url="https://github.com/sarugaku/shellingham"
+arch="noarch"
+license="MIT"
+depends="python3"
+makedepends="py3-setuptools"
+source="$pkgname-$pkgver.tar.gz::https://github.com/sarugaku/shellingham/archive/$pkgver.tar.gz"
+builddir="$srcdir/$_realname-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="ba728bed5b3c0d715e8557f8364e98eebc006a4375b6e1a9c4be92571cd71c7bf6856571f3bf66879c8075fdfebc0a54a6a5190c40811b028616c5b28808d832 py3-shellingham-1.3.1.tar.gz"