aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-sphinx-theme-bw/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-sphinx-theme-bw/APKBUILD')
-rw-r--r--testing/py3-sphinx-theme-bw/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/testing/py3-sphinx-theme-bw/APKBUILD b/testing/py3-sphinx-theme-bw/APKBUILD
new file mode 100644
index 0000000000..b74a3f2ba6
--- /dev/null
+++ b/testing/py3-sphinx-theme-bw/APKBUILD
@@ -0,0 +1,24 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py3-sphinx-theme-bw
+_pkgname=bw_sphinxtheme
+pkgver=0.1.8
+pkgrel=0
+pkgdesc="A black and white Sphinx theme"
+url="https://pypi.org/project/bw_sphinxtheme"
+arch="noarch"
+license="BSD-3-Clause"
+depends="py3-sphinx"
+makedepends="py3-setuptools"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="a89d9892d431ddf916d6ad4eebe43c2fa7ce2a079c926f9f8e12ea54e3a0c2a76cc933e9365ea811c72cd19a7737c6972b9cc52009ee1d4bfda81bd7a948b50e bw_sphinxtheme-0.1.8.tar.gz"