aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-sphinxcontrib-cartouche
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-sphinxcontrib-cartouche')
-rw-r--r--testing/py3-sphinxcontrib-cartouche/APKBUILD40
1 files changed, 13 insertions, 27 deletions
diff --git a/testing/py3-sphinxcontrib-cartouche/APKBUILD b/testing/py3-sphinxcontrib-cartouche/APKBUILD
index 2bd2f3704b..e09c8d088c 100644
--- a/testing/py3-sphinxcontrib-cartouche/APKBUILD
+++ b/testing/py3-sphinxcontrib-cartouche/APKBUILD
@@ -1,41 +1,27 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py-sphinxcontrib-cartouche
+pkgname=py3-sphinxcontrib-cartouche
_pkgname=cartouche
-pkgver=1.1
-pkgrel=1
+pkgver=1.1.2
+pkgrel=0
pkgdesc="Sphinx cartouche extension"
-url="https://code.google.com/p/cartouche/"
+url="https://github.com/rob-smallshire/cartouche"
arch="noarch"
-license="BSD"
-depends="python2 py-sphinx"
-depends_dev=""
-makedepends="python2-dev py-setuptools"
-install=""
-subpackages=""
+license="BSD-3-Clause"
+depends="python3 py3-sphinx"
+makedepends="py3-setuptools"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
-_builddir="$srcdir"/$_pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+replaces="py-sphinxcontrib-cartouche" # Backwards compatibility
+provides="py-sphinxcontrib-cartouche=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- cd "$_builddir"
- python2 setup.py build || return 1
+ python3 setup.py build
}
package() {
- cd "$_builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-md5sums="9184415c782c1b715dc50d6d5a70bd9e cartouche-1.1.tar.gz"
-sha256sums="01e44e89d609785f97920303918c272939ec9ce7b060374a3bc2adf7db6c7043 cartouche-1.1.tar.gz"
-sha512sums="61428f1ec5c690f59d81925af716dc6747c7a2192179ca8cb91c4019248014015159c531df5355f6eeef11bcd7a3e17eb30c420ec8cd3f082fe60ca428dd7218 cartouche-1.1.tar.gz"
+sha512sums="cbfc11d9ff545b9d891e218804627a9524af513c1c2eff461c41813b99f7db1336bd14ed95dbf6b5cfcce19f91ac817bb42cd660057b9bf6427daccb4b375462 cartouche-1.1.2.tar.gz"