aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-websockets/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-websockets/APKBUILD')
-rw-r--r--testing/py3-websockets/APKBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/testing/py3-websockets/APKBUILD b/testing/py3-websockets/APKBUILD
index 11a7c58ae0..7c101a34f2 100644
--- a/testing/py3-websockets/APKBUILD
+++ b/testing/py3-websockets/APKBUILD
@@ -2,14 +2,14 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py3-websockets
_pkgname=websockets
-pkgver=4.0.1
+pkgver=7.0
pkgrel=0
pkgdesc="An implementation of the WebSocket Protocol (RFC 6455)"
url="https://websockets.readthedocs.io"
arch="all"
license="BSD"
options="!check" # tox is in testing
-makedepends="python3-dev"
+makedepends="python3-dev py3-setuptools"
checkdepends="py3-tox"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
@@ -29,4 +29,4 @@ package() {
python3 setup.py install --root="$pkgdir" --optimize=1
}
-sha512sums="a60a453f33f1005c7ec7cee10f6ba6cca18628306de51872ad5a910f12f39831049f3a67ff4c3cc62efce47ce030b9e9d075d4418e8da2dcc594b8824ce21dfb websockets-4.0.1.tar.gz"
+sha512sums="3f3493c920ca3e07c143fdc443a2b1da142dda52ca6291566a3042daee6f5f702a9b091411a915da3896fe0f48cf174d9ef6fd40cf09483bc90928ee67ebd438 websockets-7.0.tar.gz"