aboutsummaryrefslogtreecommitdiffstats
path: root/testing/pylint
diff options
context:
space:
mode:
Diffstat (limited to 'testing/pylint')
-rw-r--r--testing/pylint/APKBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/testing/pylint/APKBUILD b/testing/pylint/APKBUILD
index 734529f7de..541bb2011d 100644
--- a/testing/pylint/APKBUILD
+++ b/testing/pylint/APKBUILD
@@ -2,12 +2,12 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=pylint
pkgver=1.7.4
-pkgrel=0
+pkgrel=1
pkgdesc="Analyzes Python code looking for bugs and signs of poor quality"
url="http://pypi.python.org/pypi/pylint"
arch="noarch"
license="GPL2+"
-depends="py-astroid"
+depends="py-mccabe py-six py-isort py-astroid"
makedepends="python2-dev python3-dev py-setuptools"
subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
source="https://files.pythonhosted.org/packages/source/${pkgname:0:1}/$pkgname/$pkgname-$pkgver.tar.gz"
@@ -15,8 +15,8 @@ builddir="$srcdir"/$pkgname-$pkgver
build() {
cd "$builddir"
- python2 setup.py build || return 1
- python3 setup.py build || return 1
+ python2 setup.py build
+ python3 setup.py build
}
package() {