aboutsummaryrefslogtreecommitdiffstats
path: root/testing/python26-buildutils/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/python26-buildutils/APKBUILD')
-rw-r--r--testing/python26-buildutils/APKBUILD16
1 files changed, 6 insertions, 10 deletions
diff --git a/testing/python26-buildutils/APKBUILD b/testing/python26-buildutils/APKBUILD
index 4bee0caa2b..5db0a6bfb9 100644
--- a/testing/python26-buildutils/APKBUILD
+++ b/testing/python26-buildutils/APKBUILD
@@ -1,27 +1,23 @@
# Contributor: Andrew Manison <amanison@anselsystems.com>
# Maintainer:
pkgname=python26-buildutils
-_pkgname=`echo $pkgname |sed -e 's,^python26-,,'`
+_pkgname=${pkgname#python26-}
pkgver=0.3
pkgrel=0
pkgdesc="buildutils is a collection of enhancements to the Python distutils"
url="http://pypi.python.org/pypi/buildutils/0.3"
license="GPL"
depends="python python26-setuptools"
-makedepends=""
+makedepends="python-dev"
install=
subpackages=""
source="http://pypi.python.org/packages/source/b/$_pkgname/$_pkgname-$pkgver.tar.gz"
-# append extra dependencies to -dev subpackage
-# remove if not used.
-# depends_dev="somepackage-dev"
-
build() {
- cd $srcdir/$_pkgname-$pkgver
- mkdir -p $pkgdir/usr/lib/python2.6/site-packages
- python setup.py install --root=$pkgdir
- echo "/usr/lib/python2.6/site-packages/$_pkgname-$pkgver-py2.6.egg" > $pkgdir/usr/lib/python2.6/site-packages/$_pkgname.pth
+ cd "$srcdir"/$_pkgname-$pkgver
+ mkdir -p "$pkgdir"/usr/lib/python2.6/site-packages
+ python setup.py install --root="$pkgdir"
+ echo "/usr/lib/python2.6/site-packages/$_pkgname-$pkgver-py2.6.egg" > "$pkgdir"/usr/lib/python2.6/site-packages/$_pkgname.pth
}
md5sums="fec620dee05f591edad386366b52e17b buildutils-0.3.tar.gz"