aboutsummaryrefslogtreecommitdiffstats
path: root/testing/reptyr/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/reptyr/APKBUILD')
-rw-r--r--testing/reptyr/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/reptyr/APKBUILD b/testing/reptyr/APKBUILD
new file mode 100644
index 0000000000..d0584629d2
--- /dev/null
+++ b/testing/reptyr/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: André Klitzing <aklitzing@gmail.com>
+# Maintainer: André Klitzing <aklitzing@gmail.com>
+pkgname=reptyr
+pkgver=0.6.2
+pkgrel=0
+pkgdesc="Reparent a running program to a new terminal"
+url="https://github.com/nelhage/reptyr"
+arch="all"
+license="MIT"
+makedepends="linux-headers"
+subpackages="$pkgname-doc"
+source="https://github.com/nelhage/$pkgname/archive/$pkgname-$pkgver.tar.gz
+ $pkgname-$pkgver-musl.patch::https://github.com/nelhage/reptyr/commit/319add30640feeb61a3f5af249aef5bcf3d52298.patch
+ "
+builddir="$srcdir/"reptyr-reptyr-$pkgver
+
+build() {
+ cd "$builddir"
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" PREFIX=/usr install
+}
+
+sha512sums="ad0b378d3c30bbfaa30dfcc06c405c375c7e9bcc3bae2e7fb97b8c3f88f482f461c9c846df0064cc842149b07b8a6b616d95f74cdf38f1b2a5011f6b9328c327 reptyr-0.6.2.tar.gz
+3ca4a1019dd296959f4eb12b8ace50864c2da1f9189fdbbaeea7c45d98d72371f59ebf7038564395e54f0180ccd12f7df7e60880731f7adffb05904dc4b9d9b3 reptyr-0.6.2-musl.patch"