aboutsummaryrefslogtreecommitdiffstats
path: root/testing/rocksdb/10-support-busybox-install.patch
diff options
context:
space:
mode:
Diffstat (limited to 'testing/rocksdb/10-support-busybox-install.patch')
-rw-r--r--testing/rocksdb/10-support-busybox-install.patch8
1 files changed, 4 insertions, 4 deletions
diff --git a/testing/rocksdb/10-support-busybox-install.patch b/testing/rocksdb/10-support-busybox-install.patch
index 8974dfa9a0..1e20378c33 100644
--- a/testing/rocksdb/10-support-busybox-install.patch
+++ b/testing/rocksdb/10-support-busybox-install.patch
@@ -1,17 +1,17 @@
--- a/Makefile
+++ b/Makefile
-@@ -996,14 +996,14 @@ install-headers:
+@@ -1548,14 +1548,14 @@
install -d $(INSTALL_PATH)/$$header_dir; \
done
- for header in `find "include/rocksdb" -type f -name *.h`; do \
+ for header in `$(FIND) "include/rocksdb" -type f -name *.h`; do \
- install -C -m 644 $$header $(INSTALL_PATH)/$$header; \
+ install -c -m 644 $$header $(INSTALL_PATH)/$$header; \
done
-
+
install-static: install-headers $(LIBRARY)
- install -C -m 755 $(LIBRARY) $(INSTALL_PATH)/lib
+ install -c -m 755 $(LIBRARY) $(INSTALL_PATH)/lib
-
+
install-shared: install-headers $(SHARED4)
- install -C -m 755 $(SHARED4) $(INSTALL_PATH)/lib && \
+ install -c -m 755 $(SHARED4) $(INSTALL_PATH)/lib && \