aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ruby-http-cookie/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/ruby-http-cookie/APKBUILD')
-rw-r--r--testing/ruby-http-cookie/APKBUILD39
1 files changed, 0 insertions, 39 deletions
diff --git a/testing/ruby-http-cookie/APKBUILD b/testing/ruby-http-cookie/APKBUILD
deleted file mode 100644
index 8745496762..0000000000
--- a/testing/ruby-http-cookie/APKBUILD
+++ /dev/null
@@ -1,39 +0,0 @@
-# Contributor: Francesco Colista <fcolista@alpinelinux.org>
-# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
-
-_gemname=http-cookie
-pkgname=ruby-$_gemname
-pkgver=1.0.2
-pkgrel=0
-pkgdesc="A Ruby library to handle HTTP Cookies based on RFC 6265"
-arch="noarch"
-url="https://github.com/sparklemotion/http-cookie"
-license="MIT"
-depends="ruby ruby-domain_name"
-depends_dev=
-makedepends="$depends_dev"
-source="https://rubygems.org/downloads/$_gemname-$pkgver.gem"
-_builddir="$srcdir"/$_gemname-$pkgver
-build() {
- mkdir -p "$_builddir" || return 1
- export _gemdir="$(ruby -rubygems -e'puts Gem.default_dir')"
- gem install $_gemname -v $pkgver -i "$_builddir"$_gemdir \
- --ignore-dependencies \
- --verbose \
- --no-rdoc \
- --no-ri \
- || return 1
- rm -rf "$pkgdir"/$_gemdir/cache \
- "$pkgdir"/$_geminstdir/ext \
- "$pkgdir"/$_geminstdir/.require_paths
-}
-
-package() {
- mkdir -p "$pkgdir" || return 1
- cp -ra "$_builddir"/* "$pkgdir"/ || return 1
- install -D -m644 "$pkgdir/$_gemdir/gems/$_gemname-$pkgver/LICENSE.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENSE.txt"
-}
-
-md5sums="70529d56540a162f52ce361a389a0307 http-cookie-1.0.2.gem"
-sha256sums="bcc1b18b5bc3e9302542c9c7f68f1ac0c3100a65dd2831786172e8676773e233 http-cookie-1.0.2.gem"
-sha512sums="447b7fcfd67f64edbd8420672add7ff04f28358ecd8ef59c3bf861b48378729d02bc1e4396259104651794e011ef0de72c892f28fd658474a1fc315b9b750178 http-cookie-1.0.2.gem"