aboutsummaryrefslogtreecommitdiffstats
path: root/testing/rutorrent/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/rutorrent/APKBUILD')
-rw-r--r--testing/rutorrent/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/testing/rutorrent/APKBUILD b/testing/rutorrent/APKBUILD
new file mode 100644
index 0000000000..792ff332d0
--- /dev/null
+++ b/testing/rutorrent/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Francesco Colista <francesco.colista@gmail.com>
+# Maintainer: Francesco Colista <francesco.colista@gmail.com>
+pkgname=rutorrent
+pkgver=3.5
+pkgrel=0
+pkgdesc="Yet another web front-end for rTorrent"
+url="http://code.google.com/p/rutorrent/"
+arch="noarch"
+license="GPL"
+depends="php curl gzip coreutils"
+depends_dev=""
+makedepends=""
+pkggroups="rutorrent"
+install="$pkgname.pre-install $pkgname.post-install"
+subpackages=""
+source="http://rutorrent.googlecode.com/files/$pkgname-$pkgver.tar.gz"
+_builddir="$srcdir"/$pkgname
+
+build() {
+ cd "$_builddir"
+}
+
+package() {
+ cd "$_builddir"
+ install -d $pkgdir/usr/share/webapps/$pkgname
+ install -d $pkgdir/var/www/localhost/htdocs/
+ cp -r * $pkgdir/usr/share/webapps/$pkgname
+ chgrp -R rutorrent $pkgdir/usr/share/webapps/$pkgname/share
+ chmod 0775 $pkgdir/usr/share/webapps/$pkgname/share/settings
+ chmod 0775 $pkgdir/usr/share/webapps/$pkgname/share/torrents
+ chmod 0775 $pkgdir/usr/share/webapps/$pkgname/share/users
+}
+
+md5sums="210cbabe0ead88c865c654bab2109e92 rutorrent-3.5.tar.gz"