aboutsummaryrefslogtreecommitdiffstats
path: root/testing/rutorrent/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/rutorrent/APKBUILD')
-rw-r--r--testing/rutorrent/APKBUILD42
1 files changed, 0 insertions, 42 deletions
diff --git a/testing/rutorrent/APKBUILD b/testing/rutorrent/APKBUILD
deleted file mode 100644
index 738cd8fc65..0000000000
--- a/testing/rutorrent/APKBUILD
+++ /dev/null
@@ -1,42 +0,0 @@
-# Contributor: Francesco Colista <francesco.colista@gmail.com>
-# Maintainer: Francesco Colista <francesco.colista@gmail.com>
-pkgname=rutorrent
-pkgver=3.7
-pkgrel=2
-pkgdesc="Yet another web front-end for rTorrent"
-url="http://code.google.com/p/rutorrent/"
-arch="noarch"
-license="GPL"
-depends="php5 curl"
-depends_dev=""
-
-# we need to user gnu tar since the permissions on files in tar archive are
-# bad
-makedepends="tar"
-
-pkggroups="rutorrent"
-install="$pkgname.pre-install $pkgname.post-install"
-subpackages=""
-source="http://dl.bintray.com/novik65/generic/ruTorrent-$pkgver.zip"
-_builddir="$srcdir"/ruTorrent-master
-
-
-build() {
- cd "$_builddir"
- chmod -R u+w "$_builddir"
-}
-
-package() {
- cd "$_builddir"
- install -d $pkgdir/usr/share/webapps/$pkgname
- install -d $pkgdir/var/www/localhost/htdocs/
- cp -r * $pkgdir/usr/share/webapps/$pkgname
- chgrp -R rutorrent $pkgdir/usr/share/webapps/$pkgname/share
- chmod 0775 $pkgdir/usr/share/webapps/$pkgname/share/settings
- chmod 0775 $pkgdir/usr/share/webapps/$pkgname/share/torrents
- chmod 0775 $pkgdir/usr/share/webapps/$pkgname/share/users
-}
-
-md5sums="8ef91254d5bbf45da3e1d1962b6fe8e7 ruTorrent-3.7.zip"
-sha256sums="c1fb86317231c8e8fa9e1a7dea450ce4687d94caad22d763bc68d90c56d0749f ruTorrent-3.7.zip"
-sha512sums="b8e1173e39f90c21903f3f5cc39377fb7a874bd2023130f4ffba6927ed85583c7934709eea130b1871f217f873c888fc42d53a0f9bb3ee4397f01b3aff850660 ruTorrent-3.7.zip"